SyntaxHighlighter

2010/06/05

How to Install Mercurial-1.5.4 on CentOS-5.5


Because my CentOS got ver.5.5, I upgraded Mercurial to 1.5.4 as well. I noticed many Mercurial fan using CentOS come to this site searching for "CentOS Mercurial". I think to install Mercurial as a RPM package is very useful and there are some needs. So I decided to write the install memo again.

Please note this memo is based on former posts(1, 2). If dependency problem happens, former posts should be referred.

I changed steps from former versions to use the environment variable MVER so that the steps can be applicable for any version.

12 件のコメント:

Hakan さんのコメント...

Very useful indeed, thanks!

Gadelkareem さんのコメント...

got that! thanks

dh さんのコメント...

# rpmbuild -tb mercurial-1.6.4.tar.gz
got error
error: Failed build dependencies:
python-docutils >= 0.5 is needed by mercurial-1.6.4-0.i386

uep さんのコメント...

I also got same error.
How can we install python-docutils?

moririn-japan さんのコメント...

Hi dh and uep,

Many thanks for your comments. I didn't know the new release of Mercurial.

I checked the spec file to build the RPM. The package name depended was just changed.
docutils=>python-docutils

So please use the followings instead of line8:
sed -i -e's/, python-docutils >= 0.5//' contrib/mercurial.spec

I successfully built the new RPM of 1.6.4.

Thanks.

Darpan Dinker さんのコメント...

if on 64 bit CentOS/RedHat, /usr/src/redhat/RPMS/i386/mercurial-1.5.4-0.i386.rpm has to be replaced with /usr/src/redhat/RPMS/x86_64/mercurial-1.5.4-0.x86_64.rpm

moririn-japan さんのコメント...

Darpan,

Many thanks for the useful information. Unfortunately I don't have a 64bit environment. I appreciate your comment!

7flush さんのコメント...

nice one. Thanks a lot.

7flush さんのコメント...

thanks

Michael Plunkett さんのコメント...

Thank you!!

augomat さんのコメント...

thanks!!!

some slight modifications, some more yums, wget's and rpm -Uvh for missing dependencies but for now mercurial 1.9.3 seems to work fine :)

alexacron さんのコメント...

For "rpmbuild: command not found" do:


yum install rpm-build rpmdevtools